Visual C++ Express 2005

I need it because I link to library compiled with Visual C++ 6 and the ABI is not compatible with g++. The good news is it’s
“free for 1 year”. I had 2 problems, porting my application from Visual C++ 6:

  • The msvcr80.dll problem can be fixed in Configuration Properties > C/C++ > Code Generation > Runtime Library. Set it to /MT or /MTd. Be sure to link with LIBCMT.LIB (not MSVCRT.LIB) if you have disabled default libs.
  • I disabled Common Language Runtime in Configuration Properties > General because it was dramatically slowing down my JNI libraries.