Which glibc version for my Linux kernel ?

Here is a sum up of glibc kernel headers requirements taken from glibc README git history.

glibc version Linux headers version requirement
2.26 to 2.30 3.2 or later
2.24 to 2.25 2.6.32 or later for i[4567]86 and x86_64, 3.2 or later for other architecture
2.20 to 2.23 2.6.32 or later
2.17 to 2.19 2.6.16 or later
2.4 to 2.16 2.6.0 or later, make check fail if < 2.6.16

Updated on 2019-09-12

#glibc, #linux